Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #821

    wererogue
    Participant

    One of my (locally developed) applications is always considered “not open” by Mosaico, causing every layout switch to launch a new instance of the application. I’ve tried running it as an administrator in case it’s a privilege issue but the behavior was the same.

    The only clues I can find as to why it might be failing to get this window are:
    – The process was launched by and is attached to a debugger (Visual Studio 2015)
    – The process was launched with a relative path (C:\path\to\solution\project\..\appname.exe)

    I’m not sure if either of those is the real issue, but it’s a big blocker to me getting good use of mosaico – otherwise I’m liking it a lot, it goes a long way to making me feel as comfortable in windows as I am in i3wm.

    #824

    admin
    Keymaster

    Hi! You may try to edit the command line for your application in the snapshot. The same app launched with different arguments is considered by Mosaico as two different apps.

    #826

    wererogue
    Participant

    Thanks! I’ll give that a try. I did already try setting the relative path and sadly that didn’t seem to work.

    Actually, is there a way to make an application for a snapshot optional? It’d be great if, for certain applications, they’d be repositioned if open but *not* launched when they’re missing. That’d help me a lot in this case – I don’t ever want mosaico to launch this application (because the debugger will launch it) but I do want it to handle the application if it’s running.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.